Bug Report - Missing Graphics
  • Ponkool4Ponkool4
    Open Alpha Player
    Upon running Raetikon.exe for the first time and starting the game, I immediately discovered a significant bug. No graphics appear on the screen whatsoever. Text is shown, such as "# Slivers" and the [Tab] Menu, but the rest of the screen is plain black.
    I realize this is an Alpha version, so I'm just letting you know so that you can improve it.
    I'm using Windows 8 Enterprise. If there's any other information you need, just let me know.

    Ponkool4
    Ponkool4 - computer scientist, student
  • ClemensClemens
    Administrator
    Hey Ponkool!

    Thanks for letting us know - this is a bug we have had before and many time we thought we had fixed it, but it seems to be still lurking somewhere in the code. Could you give us your system specs so we can try to fix this?
    Thanks,
    Clemens
    Clemens - Co-Founder & Artist @ Broken Rules
    @Rostiger
  • Ponkool4Ponkool4
    Open Alpha Player
    Sure thing:

    Operating System: Windows 8 Enterprise
    Processor: Intel Core i7-3687U CPU @ 2.10GHz 2.60 GHz
    Installed Memory (RAM): 12.0 GB (11.9 GB Usable)
    System Type: 64-bit Operating System, x64-based processor
    Pen and Touch: Pen and Full Windows Touch Support with 10 touch points

    I hope that's what you were looking for. Let me know if you need anything else.

    Ponkool4
    Ponkool4 - computer scientist, student
  • ClemensClemens
    Administrator
    Just one more thing: what's your graphic card?
    Clemens - Co-Founder & Artist @ Broken Rules
    @Rostiger
  • Ponkool4Ponkool4
    Open Alpha Player
    Intel HD Graphics 4000
    Ponkool4 - computer scientist, student
  • ClemensClemens
    Administrator
    Ok thanks, we'll look into it as soon as possible so you get to play the alpha as well - sorry for the inconvenience!
    Clemens - Co-Founder & Artist @ Broken Rules
    @Rostiger
  • Ponkool4Ponkool4
    Open Alpha Player
    It's no problem. I'm just glad that I get to help you guys develop your game! Plus, finding glitches can be pretty fun sometimes.
    Ponkool4 - computer scientist, student
  • fisherfisher
    Open Alpha Player
    Hey guys, Getting the same bug. Same graphics card as the guy above.

    Operating system: Windows 8 Pro
    Processor: Intel Core i5-3317U CPU @ 1.70GHz
    4GB ram

  • ClemensClemens
    Administrator
    Here's a quick jab at fixing this: try hitting alt+tab and see if your firewall has popped up. Allow the game internet access and go back into the game (or restart).
    Clemens - Co-Founder & Artist @ Broken Rules
    @Rostiger
  • Ponkool4Ponkool4
    Open Alpha Player
    I tried it, but there was no firewall popup. I suppose that's not the problem.
    Ponkool4 - computer scientist, student
  • ClemensClemens
    Administrator
    Hmm, well that shucks! I'll forward it to Peter, I'm sure he'll be thrilled to hear it! : )
    No seriously, we'll try to fix it ASAP.

    @fisher: please try as well and see if it does anything for you. Thanks!

    [edit]
    One more question:
    Can you hear sounds or music when you start the game?
    [/edit]
    Clemens - Co-Founder & Artist @ Broken Rules
    @Rostiger
  • Ponkool4Ponkool4
    Open Alpha Player
    Yes, the music and sound effects play clearly and correctly.
    Ponkool4 - computer scientist, student
  • ClemensClemens
    Administrator
    Ah! So Peter just informed me that alt+tab doesn't work in fullscreen mode, so there's no way to tell if the firewall has popped up or not (it pops up in the background). The way to fix this is to start in windowed mode.
    To do this, open the options.xml that can be found here:
    C:/Users/%USERNAME%/AppData/Roaming/Raetikon/Options.xml

    Change the fullscreen value to 'false', like so:

    <rendering>
            <fullscreen value="false" />
            <windowSize value="1280 720" />
    </rendering>

    Also make sure to decrease your window size as shown above, so you will actually see your desktop.
    Hope this helps!
    Clemens - Co-Founder & Artist @ Broken Rules
    @Rostiger
  • atomicatomic
    Open Alpha Player
    Also having issues. All I can see is an ephemeral red bar and the text '0 slivers'. I did what you suggested: edited options.xml and deactivated my firewall. No luck.
    Basic Windows 8 64-bit
    Intel Core i5-3210M CPU @ 2.50GHz
    Intel(R) HD Graphics 4000

    I have a second card (AMD Radeon HD 7670M) but I haven't deliberately switched to it yet.
  • atomicatomic
    Open Alpha Player
    Ok it worked with my secondary card (firewall anf full screen reactivated) so I think the problem lies with Intel HD Graphics (as it often does unfortunately). Also the game crashes if I switch from full screen to windowed mode.
  • ClemensClemens
    Administrator
    @atomic Aww man, that's no good. Well at least it runs with your secondary card.
    I'll add you to the list, I hope we get this sorted out soon.

    Could anybody else get it to work with the fix posted above?
    Clemens - Co-Founder & Artist @ Broken Rules
    @Rostiger
  • Ponkool4Ponkool4
    Open Alpha Player
    Nope, it still didn't work. I've checked the desktop during multiple sessions, and there has been no firewall popup. I'm afraid I don't have a secondary graphics card to try it on.
    Ponkool4 - computer scientist, student
  • fisherfisher
    Open Alpha Player
    Nope that didnt do it. I changed to windowed, I did get a firewall popup, but after allowing access and restarting the game i still didn't have any graphics.
  • peterpeter
    Administrator
    I uploaded a pre-alpha5 build here: www.secrets-of-raetikon.com/Alpha/Raetikon_pre_alpha5.zip

    We fixed some graphics issues on a windows 8 64bit HD4000 notebook, although we didn't have a black screen, some particle shaders didn't work properly. Maybe, hopefully, this fixes your problems.

    Please ignore any gameplay bugs, this version is completely untested and only intended to fix the black screen bug. 

    Could you give it a try? Thanks!
    Peter - Co-Founder, TecHead & Physics Puppeteer @ Broken Rules
    @blunzn
  • Ponkool4Ponkool4
    Open Alpha Player
    I downloaded it and tried it out, but it didn't fix the problem. The screen looks the same as before.

    Here's a screenshot, so you know exactly what I'm looking at.
    As you can see, there's a thin white line at the bottom left corner, which shows up and oscillates depending on where FInk's position is. i.e. if I fly up, it goes away, but when I come down it's there. Other than that line, the health bar, and the "slivers" text, the screen is black.
    Hopefully that extra info will help.
    Ponkool4 - computer scientist, student
  • peterpeter
    Administrator
    another idea:
    Could you please add those lines to your options (C:/Users/%USERNAME%/AppData/Roaming/Raetikon/Options.xml)

    <rendering>
    <postProcessing value="false" />
    </rendering>

    if you already have these enclosing <rendering> tags, don't add them again but just paste 
    <postProcessing value="false" />
    into this group.

    thanks. fingers crossed.


    Peter - Co-Founder, TecHead & Physics Puppeteer @ Broken Rules
    @blunzn
  • peterpeter
    Administrator
    @fisher: are you using an Intel HD 4000 graphics too?
    Peter - Co-Founder, TecHead & Physics Puppeteer @ Broken Rules
    @blunzn
  • Ponkool4Ponkool4
    Open Alpha Player
    Good news! Adding "<postProcessing value="false" />" worked!
    I can now see the graphics (I'm running the Alpha 4 .exe, not the Pre-Alpha 5). They appear a bit choppy in some places, though. Fink, in particular, doesn't have smooth edges. Also, on the title screen, the tree is a bit pixel-y. Is this how the graphics should be, or have they been somehow affected by the "<postProcessing value="false" />" code? I've added two screenshots so you can check what it looks like: (Picasa scaled down the images, so they may be difficult to see)

    Fink - First Level
    Title Screen

    Also, should I keep the Pre-Alpha 5 build or should I delete those files and just keep Alpha 4?
    Ponkool4 - computer scientist, student
  • peterpeter
    Administrator
    1) OH YEAH!

    2) with the post processing step disabled you don't have antialiasing anymore, thats why all edges appear way more pixely (you can see "steps" in all non-horizontal or non-vertical lines). but now as we know what doesn't work we can fix it. 

    3) we will send out the alpha5 build later today, just wait for that one. cheers!

    Peter - Co-Founder, TecHead & Physics Puppeteer @ Broken Rules
    @blunzn
  • peterpeter
    Administrator
    Dear Raeti who can't enjoy the pleasures of antialiased graphics!

    Could you play this build: 
    www.secrets-of-raetikon.com/Alpha/RaetikonGLdebuggerWin.zip

    and send us your 
    C:/Users/%USERNAME%/AppData/Roaming/Raetikon/Ginkgo.log file? 
    This would help us a lot with debugging these blackscreen issues.
    This build dumps lots of OpenGL infos, so it will run rather slow.

    Thanks a lot!
    Peter - Co-Founder, TecHead & Physics Puppeteer @ Broken Rules
    @blunzn
  • peterpeter
    Administrator
    hey @Ponkool4!

    did you ever find time to test the build above? It would really help us a lot! 
    Don't forget to turn postProcessing on again before trying!

    thanks & kind regards!
    Peter - Co-Founder, TecHead & Physics Puppeteer @ Broken Rules
    @blunzn

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google Sign In with OpenID