[Alpha 6] Gamepad control issues - grabbing gets stuck
  • ZrephelZrephel
    Open Alpha Player
    I'm using an old Playstation controller hooked up through an adapter, identifying itself as a "MP-8800 Quad USB Joypad". The button mappings not being quite correct is not particularly a surprise (is there a way to reconfigure them? I've tried using x360ce but it doesn't work). That'd be workable, though, except for some other very strange behavior - when I grab an object, it will constantly spark and buzz as if I'm grabbing it every frame for as long as I hold the button, and I'm unable to drop it. This, of course, essentially makes the game unplayable. Any ideas on what I should do to fix this?
  • ClemensClemens
    Administrator
    Hmm, sounds like you controller is constantly firing the grab buttonDown event, although that should only happen once when you actually press it. This is strange. You say it's an old controller? So, no bluetooth support I suppose? This has been causing problems for some people (including me).

    As far as I know, there currently isn't a way to re-configure gamepad buttons, the only keys that can be re-configured are the keyboard buttons. However you COULD map those to you gamepad with something like Gamepad Companion. However, I'm not sure if that wouldn't lead to double input for all keys.

    Is the controller behaving weird in other programs too? It might be just that the button is broken...?
    I'll let Peter/Martin/Jan know and one of them will look into it!
    Clemens - Co-Founder & Artist @ Broken Rules
    @Rostiger
  • v01pev01pe
    Administrator
    This was a gameplay bug, nut a controller issue and should be solved in Alpha 10!
    Jan - Co-Founder, Gameplay & Audio Coder @ Broken Rules
    twitter.com/v01pe_

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google Sign In with OpenID